ProjectRIK 1210

Build date: May 29 2015

===> Engine
===> Files and settings
===> Client
===> Graphics
===> Shaders
===> Sound
===> Freestyle map
[ERROR] C:\Users\Jonathan\AppData\Roaming\ProjectRIK\Data\_client.dll failed to
load with message: Failed loading C:\Users\Jonathan\AppData\Roaming\ProjectRIK\D
ata\_client.dll: Not enough storage is available to process this command.

Sys_LoadDll(_client) failed to load library
[CRITICAL ERROR] Failed to load _client.dll

What do i do?

do u have a notebook with two graphic cards?

do u have a notebook with two graphic cards?

if you dont know it:

start button -> search -> device manager -> graphic

which graphic cards are listed?

do u have a notebook with two graphic cards?

if you dont know it:

start button -> search -> device manager -> graphic

which graphic cards (or devices) are listed?

hey can you try these steps and see if they help. Making sure that it uses the nvidia GPU in the settings. Project rik should be located at %appdata%\ProjectRIK

I have a old graphcard, radeon 4800 hd, maybe its just too shitty?

You know what, im Stupid, i didnt even read the message. It says not enough storage. Sure you have space on your hard drives?

also could you tell us the following :

Operating system (including if 32 or 64 bit), and ram.

The problem shouldn't be your graphics card. It loads the game but fails to load the _client.dll, which means the graphical part of it should have worked out.

This is only a problem on 32-bit (x86) Windows 7 from what I know.

One other person had this bug before. And I tried it on a clean Windows 7 install, and was able to reproduce it. And then I fixed the problem so it worked on my clean Windows 7. But the problem was still present on the other person's computer. We tried a few things with no luck, so at the moment, I'm not sure what causes it.

There is one thing you could try though:

Other than that, from what I've read from googling, it seems like the cause can be corrupt\damaged Windows system files. Seen a lot of suggestions for running "sfc /scannow" which checks if your system files are "ok".

Same problem here but sometimes works fine. So this is very interesting bug. I hope can fix it sooooon :)

Hmmm. I try this and working. :O Problem solved :D but still not like alt+tab and gfx_restart ( if i do i got critical error)

gfx_restart is broken atm, it's not intended to work even. Just left it available "in case" someone would have use for it.

Does it work all the time now after you applied that fix? I also stumbled upon some code I can try to override any windows settings for it, so if that solution doesn't work for someone (cocosbell?) then we could try that as well :)

It's working fine in the last night. But when i woke up and try to play is not working again.. Critial error.

I check regedit (IRPStackSize) and set again the decemial value because the value is changed (i dont know why and how but now 25 for me :D), restarting my computer and now i can play again :D So i don't know.

If the Steam is running, Rik cant load _client.dll. When i close it. Its works :D

So steam is actively sabotaging non-steam games. Nice.

Will look into it later.

Same problem with app.. -.-

Not sure if that's the cause. I can run app, Steam & RIK at the same time np

Hm. Now works for me too ( Mybe its random error?

Can you make it happen still? Is it like 1/5 times for example? Any relation to reboots? If you can make it happen some times, or quite often at least, I could send you a custom build to test some things to see if it makes a difference.. :)